Nos servidores com o PHP 5.5.* é mostrado o erro mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO.

Este erro ocorre em scripts desatualizados porque a função “mysql_connect” foi removida.

Correção: Substituir a função “mysql_connect” pela função “mysqli_connect” na linha do arquivo indicado na mensagem de erro.

Mais informações: Funções Descontinuadas no PHP 5.5.*